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DataZen Installation 
The universal, out-of-band data replication and Change Data Capture engine. 

 

This documentation provides installation and first-time configuration settings of the DataZen Manager 

application and a Self-Hosted DataZen Agent.  

 

Last Updated On:  July 31s t 2025 
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Pre-Requisites 
To successfully install and configure DataZen you will need the following: 

• A windows server running 2019 or higher 

• .NET 4.7.2 framework installed 

• SQL Server 2019 or higher (express edition is sufficient for most implementations) 

NOTE: You may need additional ODBC drivers depending on the data sources you will be accessing.  

DataZen Manager Installation 
To Install DataZen Manager the first time, follow these instructions. 

 
https://www.enzounified.com/downloads/releases/datazen/v3/datazenmanager.exe 

 

 
Download the DataZen Manager EXE file  
 

For example: 
 
C:\Program Files\EnzoUnified\DataZenManager\ 
 

 
Create a Directory where the manager 
will be installed 

 
 

 
Unblock the DataZenManager.exe file 
 

 
 

 
Start the DataZenManager.exe as an 
administrator to allow the application to 
download its dependencies.  
 

https://www.enzounified.com/downloads/releases/datazen/v3/datazenmanager.exe
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If or when prompted by Windows, click OK and/or Allow to enable the application to start and 
download files. 

 

 

 
If this is the first time you run the 
Manager on this machine, you will be 
prompted the following screen.  
 
Click on Start DataZen Manager without 
an agent 
 
 

 

 
 

 
 
Before proceeding, check for DataZen 
Manager updates by choosing the 
corresponding menu item under the 
Help menu.  
 
If an upgrade is applied, make sure you 
restart the Manager with 
Administrative privileges.  
  

 
Create the following folders (you can name them differently; they 
will be used in the next step) 
 
C:\tmp\ 
C:\tmp\DATASYNC\ 
C:\tmp\DLQ 
 

• The c:\tmp\DataSync folder will be for change logs 

• The c:\tmp\DLQ (Dead Letter Queue) path specifies the default 
location for failed change logs, if used by a job 

 

 

 
Create three folders  
 
 

 
Enter the folders created above in the three paths provided.   
 
If desired, enter a Request Timeout in seconds if agents are located 
remotely; for most installations, leave this field blank. 
 

 
Open the Configuration -> Options 
screen 
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You can also specify a default text editor which is available when 
evaluating HTTP payload responses.  
 
To prevent DataZen from detecting automatic updates and using 
cloud-based HTTP/S job definitions, check the Disable Automatic 
Online Updates box.  
 
NOTE: Checking this box will disable certain features of DataZen.  
 

 
 

 

 
 

 
Check that the local Users group has Full 
access to the DataZen Manager 
installation directory.  
 
If the machine Users do not have Full 
control access, certain features may not 
work correctly.  To enable Full control, 
right-click on the installation folder and 
choose Properties; then select the 
Security tab.  
 
Select Users, then click on Advanced.  
Click on Change permissions. 
 
If visible, click on the Disable 
inheritance button and choose to 
Convert inherited permissions into 
explicit permissions:   
 

 
 
Finally, select the Users permissions 
entry and click on Edit to assign Full 
Control permissions for this folder and 
all subfolders. Click OK on all open 
screens. 
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You are now ready to proceed to the agent deployment and configuration. 

DataZen Agent Deployment  

Installing and Configuring a New DataZen Agent 
 

Although DataZen Manager allows you to monitor and upgrade agents 

remotely (on other machines), installing a new agent requires using DataZen 

Manager on the machine where the agent is being installed.  

 

 

 
Select File -> New Sync Agent -> Create 
and register a new Self-Hosted agent.  
 
A new window will become visible, 
allowing you to install and configure an 
agent on the same machine where 
DataZen Manager has been installed.  
 

 

 
The Service Settings tab allows you to 
specify how the service will start and 
which port it will use. 
 
Server Name or IP: The URL DataZen 
Manager will use to connect to the agent 
 
Port Number: The TCP Port the agent will 
bind to 
 
Installation Directory: the path where the 
agent binaries will be installed 

 
Although optional, a good practice is to use the port number as part of the folder name of the 

DataZen agent; this is particularly useful if multiple agents will be deployed on the same machine. 
 

For this example, this folder indicates the agent is listening on port 9559. 
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C:\Program Files\EnzoUnified\EnzoDS9559\ 
 
 

 

 
 
Enter your license key on the License & 
Registration tab.  
 
 
To purchase or obtain a trial license, 
please contact info@enzounified.com. 
 

NOTE: An email will be sent to the email address provided with a copy of your license key.  
 

 

Select the Stage Database Connection 
tab. 
 
Click on the configure… link to setup 
access to your SQL Server database 
where the DataZen agent will store its 
internal configuration settings.  
 
 

 
The Stage Database must be SQL Server 2019 or higher, any edition, and should preferably be 
located on the same server where the agent is being installed for best performance. The database 
size may grow significantly depending on the use of Change Data Capture and the amount of data 
being captured. As a result, while SQL Server Express edition is supported, it may not be sufficient 
for situations where large data sets are being replicated with Change Data Capture engaged. 
 
Contact Enzo Support for further information. 
  
 
  

 
 
 

mailto:info@enzounified.com
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In the Database Connection screen, 
enter the following information.  
 
Database Server: The database server name 
and optionally the instance name to connect 
to 
 
Authentication: Database credentials to use 
(use Windows Authentication if possible) 
 
Database Name: Enter the name of a 
database to create (it will be created later 
automatically if needed) 

 
Click OK to close the Database 
Connection screen and fill out the 
connection string. 

 

 
In the Windows Service Registration tab, 
check the Register this agent as a 
Windows Service. This setting is 
optional; however, if this agent is not 
registered as a service, it will not start 
automatically when the machine 
restarts.  To start the agent manually, 
simply run the EnzoDS.exe file in the 
directory where the agent was installed. 
 
Service Name Suffix: Enter a suffix for the 
windows service name. Using the port 
number of the agent is generally a good 
practice. 

 
Once all the information has been filled 
out, click OK to install the agent.  This 
operation may take a few minutes.  

  

Installing new agents requires administrative privileges; it is recommended to run the 

DataZen Manager as an Administrator to ensure a successful installation. 
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Finalizing Agent Settings  
To edit the configuration of an existing agent or change its default security settings, follow these steps.  

 

 
 
Select the agent to reconfigure, 
and choose Configuration -> 
Agent Settings… 
 

 

 
This screen allows you to 
change/edit the connection 
string to the Stage database, 
change security settings, and 
change the license key. 
 
NOTE: Changing the Stage 
Connection String is not 
recommended; loss of data is 
possible. Please contact Enzo for 
guidance.  

  
  

 

 
To change access control 
settings, choose the Security tab.  
 
BUILTIN\Administrators are always 
allowed access to the agent.  
 
By default, NT 
AUTHORITY\Authenticated Users 
can administer agents. However, 
adding specific groups will limit 
access to the agents as specified.  

 
 

To change your license key, choose the License Key tab and paste it in the license key box. 
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To enable remote registration of 
agents from another DataZen 
Manager, or to enable HTTP/S 
access using Token-based 
authentication, change the 
Access Level specified in the 
Shared Access Keys tab.  
 
See the online documentation for 
more information about these 
settings.  

 
 
 

 
If you have registered X.509 
certificates with DataZen, you 
can select which certificates can 
be used for signature and/or 
authentication.  
 
Please note that if at least one 
certificate is selected under Signing 
Certificates, all connections using 
Token-based authentication must be 
signed.  

Advanced Agent Configuration 

The following configuration settings require manual changes and may cause the 

agent to stop operating successfully; as a result, it is recommended to reach out to 

the Enzo support team before making these changes. The settings below require 

changing settings in the EnzoDS.Exe.config file where the agent is installed. 

For more detailed instructions and overview of the DataZen Agent configuration settings, visit 

https://portal.enzounified.com/docs/datazen/datazen-security and 

https://portal.enzounified.com/docs/agent/Commandline  

Use HTTP/S for the Agent Listening Port 
By default, a DataZen agent listens on port 9559, which is not encrypted. While sensitive data (such as 

connection string settings) are encrypted by DataZen internally, using an HTTP/S endpoint provides 

additional security.  To use port 443 change the listenerUrl setting accordingly.  

<add key="listenerUrl" value="https://SERVERNAME" /> 

https://portal.enzounified.com/docs/datazen/datazen-security
https://portal.enzounified.com/docs/agent/Commandline
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Specify multiple TCP Ports for an Agent 
You may configure a DataZen agent to listen on multiple TCP Ports. Although DataZen Manager only 

communicates on a single port you may choose to enable the agent to use multiple ports to accept 

HTTP/S requests. For example, the following setting tells the agent to listen on both port 443 (HTTPS) 

and 9559 (HTTP).  

<add key="listenerUrl" value="https://SERVERNAME,http://localhost:9559" /> 

Configure Remote Monitoring with DataZen Manager 
DataZen Manager supports accessing and managing agents remotely; this allows you to manage jobs 

and agent configuration settings centrally. You can monitor agents remotely using any of the 

authentication methods provided in the Authentication Sequence section below.  

If you use Token-based authentication, the shared keys need to be configured to allow the 

Administrative Access Level or a Service Token with sufficient privileges.  

 

 

 
 
Start DataZen Manager on a remote 
server and choose File -> Register 
agent -> Self-Hosted Agent…  
 

 
 

 
In the Server Name field, enter the 
URL of the agent. This URL must be 
accessible from the machine where 
you are running the DataZen 
Manager application.  
 
The Display Name and Environment 
settings are optional. 
 
Select Token-Based Authentication 
and paste the access token of the 
agent.   
 
Alternatively, you can choose an 
X.509 certificate for authentication 
(see the X.509 Authentication 
section for more information). 
 
Click Register 
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Once registered, you will see the 
agent listed and will be able to 
manage its jobs remotely. 
 
To edit the registration if this agent, 
click on the gear icon or on the URL 
link.  
 
NOTE: If the URL or the port of the agent 
changes, you will need to unregister the 
agent and re-register it using the new 
URL.  

 

 

 
To view your agents in a more 
compact way, check the option 
under the View -> Compact Agent 
List menu. 
 
The Display Name and Environment 
will be displayed instead of the URL if 
configured.  
 

 

 
To view the capabilities of the 
selected agent, click on the question 
mark.  
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Authentication Sequence 
The authentication sequence to a DataZen agent is as follows: 

- Anonymous authentication, if enabled on the agent server 

- X.509-based authentication (which includes signature verification)  

- Token-based authentication, with X.509 signature verification if configured 

- NTLM authentication based on NT or AD Group settings   

To use NTLM authentication with AD Group authorization, no Authentication header 

should be present in the HTTP request.  

 

Anonymous Authentication 
This setting is controlled through a startup parameter of EnzoDS.exe: -anonymous 

It is recommended to only use this setting for initial configuration, if necessary. See the online help 

documentation (https://portal.enzounified.com/docs/agent/Commandline) for more information about 

startup parameters.  

https://portal.enzounified.com/docs/agent/Commandline
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X.509 Authentication and Signature  
X.509 signing certificates can be used for both authentication and signature purposes. In order for 

certificates to be used, they must first be registered with the agent using the Manage Certificates option 

in DataZen Manager. This ensures that the agent can access the X.509 certificates.  

In addition, the agent must be configured to select which certificates can be used for authentication 

and/or signature, as described in the Finalizing Agent Settings section.  Two tabs are available under the 

Certificates section: Signing Certificates and Authentication Certificates.  

See the online help documentation (https://portal.enzounified.com/docs/datazen/datazen-security-

x509) for more information. 

Please note that if at least one certificate is selected under Signing Certificates, all 

connections using Token-based authentication must be signed.  

https://portal.enzounified.com/docs/datazen/datazen-security-x509
https://portal.enzounified.com/docs/datazen/datazen-security-x509

